Using Loupedeck with OBS Studio 28

This is a workaround for using Loupedeck devices with new OBS Studio 28. Our Loupedeck plugin will be updated soon.

Instructions for Windows

Instructions for MacOS

 

Windows

Download and install new websocket

  • Close OBS Studio
  • Copy this location to Windows Explorer search bar: 

    C:\Program Files\obs-studio\obs-plugins\64bit and remove loupedeck-obs.dll file

 

 

Review websocket settings

  • Open OBS Studio
  • At the top, select Tools -> WebSockets Server Settings (4.x Compact)
  • Make sure you see the following options checked in the WebSockets Server Settings window:
      1. “Enable WebSockets server” must be ON
      2. “Enable authentication” must be OFF (as this is a local server, it does not represent any security risk)

  • Close OBS Studio

 

Create new websocket file

  • Copy this location to Windows Explorer search bar: %LOCALAPPDATA%\Loupedeck\PluginData\ObsStudio

💡 Note that the AppData folder might be hidden. To access it, please click on the View tab in Explorer and check the Hidden items box. 

 

If it is still not possible to use Loupedeck in OBS 28, we recommend to temporarily downgrade OBS Studio to the previous version. Our team is currently working on Loupedeck plugin update and feel free to get in touch with our Support team with additional questions. 

 


 

MacOS

Download and install new websocket

  • Close OBS Studio
  • Find this location in Finder: /Library/Application Support/obs-studio/plugins/
  • Locate loupedeck-obs.dll file and delete it
  • Go to https://github.com/obsproject/obs-websocket/releases and download obs-websocket-4.9.1-compat-Qt6-macOS.pkg file
  • Run the installer and follow the installation guide 

 

Review websocket settings

  • Open OBS Studio
  • At the top, select Tools -> WebSockets Server Settings (4.x Compact)
  • Make sure you see the following options checked in the WebSockets Server Settings window:
      1. “Enable WebSockets server” must be ON
      2. “Enable authentication” must be OFF (as this is a local server, it does not represent any security risk)

  • Close OBS Studio

 

Create new websocket file

  • Find this location in Finder: /.local/share/Loupedeck/PluginData/ObsStudio/

💡 Please note the .local folder is hidden and you need to press "cmd + shift + dot" to see it.

If it is still not possible to use Loupedeck in OBS 28, we recommend to temporarily downgrade OBS Studio to the previous version. Our team is currently working on Loupedeck plugin update and feel free to get in touch with our Support team with additional questions.