Loupedeck Live System Requirements

What do I need so I can use Loupedeck Live?

Any computer that can run either

  • Windows 10
  • MacOS 10.14 or higher

and has

  • USB-C connectivity (or USB-A when using USB C-to-A adapter)
  • Internet connection (to download Loupedeck software)

No other requirements.